header

Faculty of Economics

Minimum Web Browser Requirements

The Faculty web pages require a minimum web browser of Microsoft Internet Explorer 7.0 or higher, Mozilla Firefox 2.0 or higher, Apple Safari 3 or higher, Opera version 8 or higher, or any version of Google Chrome to view these pages correctly.

If you are not sure of the version of your browser, select Help in the menu bar of your browser and choose About.

You need to upgrade your Web browser if you have trouble viewing the site.

Javascript

The Faculty web pages require your web browser to support Javascript. By default, the major web browsers are configured to handle this requirement.